X1
Resource CenterDownloadsProductsNews & EventsPartnersAbout UsSupport
Products
X1 Professional Client
X1 Professional Client Requirements and FAQ

System Requirements

OS
  • Microsoft Windows XP SP2 or later
  • Microsoft Windows Vista
  • Windows 7
CPU
  • 1 GHz minimum, 32-bit (x86) or 64-bit (x64)
Memory
  • 1 GB RAM for 32-bit or 2 GB RAM for 64-bit
Disk
  • 1 GB free hard disk space recommended
Software
  • Microsoft .NET framework 3.0 or later
Supported Email Applications
  • Microsoft Outlook XP, 2003, 2007, 2010 (32-bit)
  • Microsoft Outlook Express 6.x
  • Mozilla Thunderbird 1.5, 2.x, 3.x
  • IBM Lotus Notes & Domino 6.5.x to 8.x

Microsoft .NET

X1 requires Microsoft's .NET 3.0 Framework or higher. While the latest releases of Windows (Vista, 7) already include .NET, you can find more information on the Microsoft .NET website and download it here.

FAQ

Can more than one release of X1 run on my PC?
No. You can install and run only one copy of X1 on your PC at any given time.

 

If I want to try a new release of X1, how do I protect my current X1 installation?
Make a copy of all X1 files you want to protect that are related to the prior release. There is no rollback feature in X1. Alternately, locate your original X1 installer so you can uninstall the new release and reinstall your original version.

 

If I'm running a version of X1 that is more than a year old, what considerations should I be aware of when installing the new release?

  1. X1 will install over your prior copy of X1. You must make a backup of X1 if you decide to rollback to the old release.
  2. If you are not on a software assurance plan with X1 – or you purchased X1 more than a year ago – you will need to purchase the new version of X1 once the 14-day trial period ends. Your old license keys will not work.
  3. If you are unsure when you purchased X1, but you have a 16-digit registration code, you will be able to register the upgrade. If you have a 13-digit code, you will only be able to run the new version of X1 in trial mode for 14 days.
 

Other than the current release of X1 (Version 6.7.2), what other releases of X1 are supported?
X1 will continue to offer version 6.2.4 for users who are unable to install or run Microsoft .NET 3.0 or higher.

TermsPrivacyContact UsSite Map
© 2003-2017 X1 Discovery, Inc. All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
X1 is an Idealab company